Prezentace se nahrává, počkejte prosím

Prezentace se nahrává, počkejte prosím

MS EXCEL – FUNKCE (předpisy zobrazující výsledek podle daného vzorce a zadaných dat)

Podobné prezentace


Prezentace na téma: "MS EXCEL – FUNKCE (předpisy zobrazující výsledek podle daného vzorce a zadaných dat)"— Transkript prezentace:

1 MS EXCEL – FUNKCE (předpisy zobrazující výsledek podle daného vzorce a zadaných dat)

2 TYPY FUNKCÍ Finanční Datum a čas Matematické Statistické Vyhledávací Databáze Text Logické Informační Inženýrské Krychle Vše Naposledy použité

3 FINANČNÍ FUNKCE – nejčastěji související se splátkami, úroky apod. DATUM A ČAS – převod data a času z textu do formátu buněk Datum a čas nebo naopak MATEMATICKÉ – základní goniometrické, exponenciální, mocninné, kombinatorické funkce STATISTICKÉ – funkce pro určení vlastností souboru dat VYHLEDÁVACÍ – určují hodnoty, čísla buněk, řádků nebo sloupců s danými parametry

4 DATABÁZE – funkce pracující s databázemi – složitými strukturami dat TEXT – sloučení, hledání, nahrazení znaků LOGICKÉ – logické operátory A, NEBO, NOT, … INFORMATICKÉ – funkce ověřující typ dat v buňce INŽENÝRSKÉ – přepočítávají čísla do jiných měrných a číselných soustav, operují s komplexními čísly KRYCHLE – funkce pro datové krychle

5 POUŽITÍ FUNKCÍ Pomocí funkčního tlačítka Použitím tvaru =NÁZEV FUNKCE() (pro zápis znaménka „=“ bez funkce se používá zápis „´=“ ) Většina funkcí obsahuje tzv. argumenty (hodnoty, se kterými funkce pracuje) oddělené středníkem tučně jsou uvedeny povinné argumenty, normálním písmem nepovinné

6 ODKAZOVÁNÍ BUNĚK Relativní odkaz: používá se automaticky, po zkopírování buňky s funkcí či vzorcem dojde k přepočítání veškerých odkazů na jiné buňky Absolutní (pevný) odkaz: při použití znaménka $ u řádku i sloupce odkazované buňky.

7 PŘÍKLAD NÁPOVĚDY K FUNKCI PLATBA Vypočítá platbu půjčky na základě konstantních plateb a konstantní úrokové sazby. Syntaxe: PLATBA(sazba;pper;souč_hod;bud_hod;typ) Sazba je úroková sazba dané půjčky. Pper je počet plateb půjčky. Souč_hod je aktuální hodnota nebo aktuální celková hodnota budoucích plateb. Bud_hod je předpokládaná budoucí hodnota. Pokud bud_hod není uvedena, je jí přiřazena 0 (budoucí hodnota půjčky, například 0). Typ je číslo 0 (nula) nebo 1 a určuje, kdy je platba prováděna. 0 nebo neuvedenNa konci období 1Na začátku období

8 R2-R33: Vytvořte funkci, která podle obsahu buňky Q zobrazí text: Nad 40 %, 40 % a méně. =KDYŽ(Q2>40;"Nad 40 %";"40 % a méně") S2-S33: Vytvořte funkci, která vypíše obsah buňky Q vynásobený opravným koeficientem (v buňce X2) =Q2*$X$2

9 Vytvořte funkci, která zobrazí náhodné číslo v intervalu <0;1) =NÁHČÍSLO() Vytvořte funkci, která vytvoří náhodnou známku 1 až 5. =RANDBETWEEN(1;5) Vytvořte funkci, která zobrazí náhodné číslo v intervalu <0;12) =12*NÁHČÍSLO() nebo =RANDBETWEEN(0;11)+NÁHČÍSLO() A35: Vytvořte funkci, která vrátí aktuální dnešní datum. =DNES() B35: Zjistěte, kolik dní svého života jste prožili. =DNES()-DATUM(vašeho narození) nebo =DAYS(dnešní datum, datum narození) A36:Vytvořte funkci, která vypíše číslo dne v týdnu, připadající na datum uvedené v buňce A35. =DENTÝDNE(A35;2)

10 A37: Vytvořte funkci, která podle obsahu buňky A36 zobrazí text: Víkend, Všední den Modifikujte funkci tak, aby zobrazovala: Neděle, Sobota, Všední den. =KDYŽ(A36>5; KDYŽ(A36=6;"Sobota";"Neděle); „Všední den") Na Internetu zjistěte možnost půjčky Kč u banky a u nebankovní instituce. Zapište si RPSN (=roční procentní sazba nákladů, „skutečný úrok“) a délku splácení. Pomocí funkce PLATBA zjistěte měsíční splátku. Určete celkovou zaplacenou částku pomocí funkce (PLATBA*počet splátek). A38-A41: Vytvořte funkce, které určí hodnoty sin, cos, tg a cotg buňky B38 =SIN(B38)=COS(B38) =SIN(B38)/COS(B38) nebo =TG(B38) =COS(B38)/SIN(B38) nebo =COT(B38)

11 Modifikujte tyto funkce tak, aby určovaly hodnoty funkcí úhlu, který bude zadán v buňce B38 ve stupních. =SIN(RADIANS(B38)) Modifikujte funkci cotg tak, aby při chybové hodnotě vypsala text „Funkce není definovaná!“ =KDYŽ(SIN(RADIANS(B38))=0;"Funkce není definovaná!"; COT(RADIANS(B38))) Nebo =KDYŽ(JE.CHYBA(COT(RADIANS(B38)));"Funkce není definovaná";COT(RADIANS(B38))) P34: Vložte funkci, zobrazující součet bodů všech žáků, kteří dosáhli více než 11 bodů v celkovém hodnocení. =SUMIF(P2:P33;">11")

12 P34: Vložte funkci, zobrazující počet všech žáků, kteří dosáhli více než 11 bodů v celkovém hodnocení. =COUNTIF(P2:P33;">11") Do buňky D40 vložte vaše jméno a příjmení. Do buňky D41 vložte funkci, která vypíše pouze křestní jméno. Do buňky D42 vložte funkci, která vypíše pouze příjmení. = ČÁST(D40;1;HLEDAT(“ “;D40)-1) Do buňky F40 vložte první šestičíslo vašeho rodného čísla. Do buněk F41-F43 vložte funkce, které zobrazí celý rok, měsíc a den vašeho narození. =ČÁST(F40;1;2)+1900=ČÁST(F40;3;2)-50

13 Do buňky D45 vložte libovolné číslo, Do buňky D46 vložte funkci, která zobrazí počet řádů tohoto čísla =DÉLKA(ZAOKROUHLIT.NA.TEXT(D45;0;PRAVDA)) =HLEDAT(",";ABS(D43))-1 Do buňky D47 vložte funkci, která vypíše slova ZÁPORNÉ/KLADNÉ/NULA podle velikosti čísla v buňce D45 =KDYŽ(D45>0;"KLADNÉ";KDYŽ(D45<0;"ZÁPORNÉ";"NULA"))

14 Do buňky D40 vložte libovolný text obsahující aspoň dvě slova. Do buňky E42 vložte funkci, která vypíše počet písmen ve větě bez mezer. =DÉLKA(DOSADIT(D40;" ";""))


Stáhnout ppt "MS EXCEL – FUNKCE (předpisy zobrazující výsledek podle daného vzorce a zadaných dat)"

Podobné prezentace


Reklamy Google